Claritude Logo
   
   

Support Links

     
 

Which Windows/Outlook versions are supported? 

SpeedFiler requires any of the following versions of Outlook:

  • Outlook 2003
  • Outlook 2007

SpeedFiler works with the above versions of Outlook on the following operating systems:

  • Windows 2000 Professional
  • Windows XP
  • Windows Server 2003
  • Windows Vista
 
     
 
Latest SpeedFiler version: 2.0.0
 
 
 
 

Copyright © 2007 Claritude Software. All rights reserved. Claritude and SpeedFiler are trademarks of Claritude Software.

OISV - Organization of Independent Software Vendors - Charter Member